侧边栏壁纸
  • 累计撰写 372 篇文章
  • 累计创建 60 个标签
  • 累计收到 109 条评论

目 录CONTENT

文章目录

Invoke-customs are only supported starting with Android O (--min-api 26) 错误解决方法

Z同学
2021-10-11 / 0 评论 / 0 点赞 / 1,045 阅读 / 273 字
温馨提示:
本文最后更新于 2021-11-18,若内容或图片失效,请留言反馈。部分素材来自网络,若不小心影响到您的利益,请联系我们删除。

问题

我们Debug运行时,都能够正常,但是执行 Build APK 打包时。提示错误

image.png

错误效果图如下所示:
image.png

主要是Android Studio 告诉我们如果要调用Custom。需要设置你的最低min-api 26版本

介绍

我们的项目,难道不能编译api 26以前的版本么?
不是的,出现这个问题的主要原因在于,我们项目中依赖的部分库。使用了java 8的字节码。

在错误详细描述中也有相关介绍:

image.png

添加到build.gradle 之中就好了

android {
    compileOptions {
        sourceCompatibility 1.8
        targetCompatibility 1.8
    }
}
0

评论区