侧边栏壁纸
  • 累计撰写 372 篇文章
  • 累计创建 60 个标签
  • 累计收到 109 条评论

目 录CONTENT

文章目录

错误:use a compatible library with a minSdk of at most 21 解决

Z同学
2021-06-29 / 0 评论 / 0 点赞 / 1,691 阅读 / 380 字
温馨提示:
本文最后更新于 2021-11-18,若内容或图片失效,请留言反馈。部分素材来自网络,若不小心影响到您的利益,请联系我们删除。

问题:
Suggestion: use a compatible library with a minSdk of at most 21, or increase this project's minSdk version to at least 28, or use tools:overrideLibrary="com.xxxx.xxxx" to force usage (may lead to runtime failures)

原因:

因为你的项目导入的aar库.设置的最低版本. minSDKVersion 要比你的项目本身设置的minSDKVersion要高.

才会出现的问题.

例如: 这个库,最低库是14. 有些aar库可能打的太高了.

image.png
解决:
1.调整你的build.gradle文件里面的 minSdkVersion 版本.不能小于aar里面的

可以大于和等于.

2.找相关aar文件提供方.咨询能否打低点版本.

0

评论区